viernes, 30 de junio de 2017

Cable usb a serial y sus drivers

En el trabajo se compro unos cables USB a RS232 chinos, no tienen ninguna marca. Y bueno al momento de conectarlo los drivers que trajo en un CD no funcionaban.

El dispositivo se veia como:
USB2.0-ser!

Leyendo en un blog encontré la solución instalando el driver de este comprimido:
https://drive.google.com/file/d/0B-VOsF2QjPcuTTM3QXRlNU95WDA/view?usp=sharing

Santo remedio, funciono perfecto con un CISCO.

Aislantes termico naturales


Muy interesante, alternativas de aislante térmico para el hogar.

Una comparativa del aislante termico de muros hecho en Argentina:

¿Cómo se hizo el estudio? 

Para cada uno de los sistemas constructivos se calculó teóricamente la Transmitancia Térmica (K) mediante la utilización de un programa de simulación numérica que analiza el fenómeno de transmisión de calor en geometría bidimensional. Como segundo paso, se aislaron dichos sistemas constructivos mediante el agregado de un material aislante térmico convencional de conductividad térmica media igual a 0,040 W/m.K, incorporando 3 pulgadas (aproximadamente 7,5cm) en el techo y 2 pulgadas (aproximadamente 5cm) en los muros. Con esta metodología se obtuvieron para cada caso las respectivas Transmitancias Térmicas, cuyos resultados se detallan en la Tabla 1.

Tabla 1: Transmitancia térmica de muros y techos evaluados 

Sistemas Constructivos 
Transmitancia Térmica [W/m²K] del muro sin aislación 
Transmitancia Térmica [W/m²K] del muro con aislación 
Muro de ladrillo hueco del 12 
2,10 
0,52 
Muro de ladrillo hueco del 18 
1,53 
0,47 
Muro de bloques de hormigón 
2,46 
0,53 
Techo de cubierta metálica 
2,50 
0,50 
Techo de losa de hormigón armado 
2,27 
0,41 


Cuadro comparativo

Descripción del MuroEspesor (cm)Transmitáncia Térmica k
w/(m².°C)kcal/(m².hora.°C)
Muro de Ladrillos HCCA200,540,47
Muro de Ladrillos HCCA17,50,620,54
Muro de Ladrillos HCCA150,700,60
Muro doble LH12 + cámara de aire 
2 cm + LH12 revocado en ambas caras 2 cm
300,910,78
Muro doble LH12 + cámara de aire 
2 cm + LH12 revocado en ambas caras 2 cm
301,010,87
Muro de ladrillo cerámico portante de 18 cm revocado en ambas caras 1 cm201,311,13
Muro de ladrillo cerámico portante de 12 cm revocado en ambas caras 1 cm151,551,33
Muro de ladrillo hueco 12 cm revocado en ambas caras 1,5 cm151,741,50
Muro de ladrillo común de 12 cm revocado en ambas caras152,682,30

sábado, 29 de abril de 2017

Firewall para mikrotik

This script has basic rules to protect your router and avoid some unnecessary forwarding traffic. Pay attention for all comments before apply each DROP rules.
HANDS ON! First we need to create our ADDRESS LIST with all IPs we will use most times
Below you need to change x.x.x.x/x for your technical subnet. This subnet will have full access to the router.
/ip firewall address-list add address=x.x.x.x/x disabled=no list=support

Below we have the bogon list.
/ip firewall address-list

add address=0.0.0.0/8 comment="Self-Identification [RFC 3330]" disabled=no list=bogons
add address=10.0.0.0/8 comment="Private[RFC 1918] - CLASS A # Check if you need this subnet before enable it"\
disabled=yes list=bogons
add address=127.0.0.0/8 comment="Loopback [RFC 3330]" disabled=no list=bogons
add address=169.254.0.0/16 comment="Link Local [RFC 3330]" disabled=no list=bogons
add address=172.16.0.0/12 comment="Private[RFC 1918] - CLASS B # Check if you need this subnet before enable it"\
disabled=yes list=bogons
add address=192.168.0.0/16 comment="Private[RFC 1918] - CLASS C # Check if you need this subnet before enable it"\
disabled=yes list=bogons
add address=192.0.2.0/24 comment="Reserved - IANA - TestNet1" disabled=no list=bogons
add address=192.88.99.0/24 comment="6to4 Relay Anycast [RFC 3068]" disabled=no list=bogons
add address=198.18.0.0/15 comment="NIDB Testing" disabled=no list=bogons
add address=198.51.100.0/24 comment="Reserved - IANA - TestNet2" disabled=no list=bogons
add address=203.0.113.0/24 comment="Reserved - IANA - TestNet3" disabled=no list=bogons
add address=224.0.0.0/4 comment="MC, Class D, IANA # Check if you need this subnet before enable it"\
disabled=yes list=bogons

Now we have protection against: SynFlood, ICMP Flood, Port Scan, Email Spam and much more. For more information read the comments.
/ip firewall filter

add action=add-src-to-address-list address-list=Syn_Flooder address-list-timeout=30m chain=input \
comment="Add Syn Flood IP to the list" connection-limit=30,32 disabled=no protocol=tcp tcp-flags=syn
add action=drop chain=input comment="Drop to syn flood list" disabled=no src-address-list=Syn_Flooder
add action=add-src-to-address-list address-list=Port_Scanner address-list-timeout=1w chain=input comment="Port Scanner Detect"\
disabled=no protocol=tcp psd=21,3s,3,1
add action=drop chain=input comment="Drop to port scan list" disabled=no src-address-list=Port_Scanner
add action=jump chain=input comment="Jump for icmp input flow" disabled=no jump-target=ICMP protocol=icmp
add action=drop chain=input\
comment="Block all access to the winbox - except to support list # DO NOT ENABLE THIS RULE BEFORE ADD YOUR SUBNET IN THE SUPPORT ADDRESS LIST"\
disabled=yes dst-port=8291 protocol=tcp src-address-list=!support
add action=jump chain=forward comment="Jump for icmp forward flow" disabled=no jump-target=ICMP protocol=icmp
add action=drop chain=forward comment="Drop to bogon list" disabled=no dst-address-list=bogons
add action=add-src-to-address-list address-list=spammers address-list-timeout=3h chain=forward comment="Add Spammers to the list for 3 hours"\
connection-limit=30,32 disabled=no dst-port=25,587 limit=30/1m,0 protocol=tcp
add action=drop chain=forward comment="Avoid spammers action" disabled=no dst-port=25,587 protocol=tcp src-address-list=spammers
add action=accept chain=input comment="Accept DNS - UDP" disabled=no port=53 protocol=udp
add action=accept chain=input comment="Accept DNS - TCP" disabled=no port=53 protocol=tcp
add action=accept chain=input comment="Accept to established connections" connection-state=established\
disabled=no
add action=accept chain=input comment="Accept to related connections" connection-state=related disabled=no
add action=accept chain=input comment="Full access to SUPPORT address list" disabled=no src-address-list=support
add action=drop chain=input comment="Drop anything else! # DO NOT ENABLE THIS RULE BEFORE YOU MAKE SURE ABOUT ALL ACCEPT RULES YOU NEED"\
disabled=yes
add action=accept chain=ICMP comment="Echo request - Avoiding Ping Flood" disabled=no icmp-options=8:0 limit=1,5 protocol=icmp
add action=accept chain=ICMP comment="Echo reply" disabled=no icmp-options=0:0 protocol=icmp
add action=accept chain=ICMP comment="Time Exceeded" disabled=no icmp-options=11:0 protocol=icmp
add action=accept chain=ICMP comment="Destination unreachable" disabled=no icmp-options=3:0-1 protocol=icmp
add action=accept chain=ICMP comment=PMTUD disabled=no icmp-options=3:4 protocol=icmp
add action=drop chain=ICMP comment="Drop to the other ICMPs" disabled=no protocol=icmp
add action=jump chain=output comment="Jump for icmp output" disabled=no jump-target=ICMP protocol=icmp

I think this is basic. You can add or remove anything else according to your needs. I hope it helps!
By Guilherme Ramires

Fuente:
https://wiki.mikrotik.com/wiki/Basic_universal_firewall_script